<!DOCTYPE html><html lang="en"><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>Weibo Corporation Launches Global Offering</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2021 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=561943943"/><meta name="google-play-app" content="app-id=com.mobdub.channel.WVIR"/><meta name="burst" content="wvir"/><meta property="og:url" content="https://www.nbc29.com/prnewswire/2021/11/26/weibo-corporation-launches-global-offering/"/><meta name="robots" content="noindex"/><meta name="googlebot" content="noindex"/><meta name="googlebot-news" content="noindex"/><meta property="fb:admins" content="644426401"/><meta property="article:publisher" content="https://www.facebook.com/NBC29/"/><meta name="keywords" content=""/><meta name="news_keywords" content=""/><meta itemProp="image" property="og:image" content="https://www.nbc29.com/pf/resources/images/logo-icons/wvir.svg?d=207"/><meta name="twitter:image" content="https://www.nbc29.com/pf/resources/images/logo-icons/wvir.svg?d=207"/><meta property="og:site_name" content="https://www.nbc29.com"/><meta property="og:title" content="Weibo Corporation Launches Global Offering"/><meta name="twitter:title" content="Weibo Corporation Launches Global Offering"/><meta name="twitter:card" content="summary_large_image"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "WVIR",
  "url": "https://www.nbc29.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.nbc29.com/pf/resources/images/logo-off-site/wvir.png?d=207"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/NBC29/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Weibo Corporation Launches Global Offering",
  "url": "https://www.nbc29.com/prnewswire/2021/11/26/weibo-corporation-launches-global-offering/",
  "image": "https://www.nbc29.com/pf/resources/images/logo-off-site/wvir.png?d=207",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "keywords": [],
  "headline": "Weibo Corporation Launches Global Offering",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.nbc29.com/prnewswire/2021/11/26/weibo-corporation-launches-global-offering/"
  },
  "author": {
    "@type": "Organization",
    "name": "WVIR"
  },
  "publisher": {
    "name": "WVIR",
    "url": "https://www.nbc29.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.nbc29.com/pf/resources/images/logo-off-site/wvir.png?d=207"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2021-11-26T19:40:00Z",
  "datemodified": "2021-11-26T19:40:00Z"
}</script><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=207" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=207" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=207" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-wvir-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=207"/><link rel="stylesheet" href="https://gray-wvir-prod.cdn.arcpublishing.com/pf/resources/dist/wvir/css/main.css?d=207"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css?d=207" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/wvir/favicon.ico?d=207"/><script type="text/javascript" src="https://gray-wvir-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=207"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2bkp9Uun3-1LRAB_lzCZndpym_6H7eOtuB69j2DMKvsxBxYzTMW8Pcb8nw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2sglPwD6cv16a0cnFC0rQ1CHpbVfM07j9ojCzxSbHxiBayPvsnqIuSLXL0EjVtTQDR7yhgNv36s",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript" src="https://gray-wvir-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=207"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires/press-releases",
        authors: [ ],
        canonicalUrl: "https://www.nbc29.com/prnewswire/2021/11/26/weibo-corporation-launches-global-offering/",
        contentId: "SF4VA5K7CVBP5JAURGY5QAKPAA",
        contentKewords: [ ],
        contentName: "Weibo Corporation Launches Global Offering",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "11/26/2021",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "PRNewswire",
        distributorReferenceId: "cc164599-a609-4ade-ad67-ab71070d59c1",
        distributorSubCategory: "prnewswire",
        hasVideo: false,
        metaDescription: null,
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires/press-releases",
          name:  "Press Releases",
          path:  "/wires/press-releases"
        },
        publishedDay: "26",
        publishedMonth: "11",
        publishedYear: "2021",
        stationName: "wvir",
        subtype: null,
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-36448567-2bd0-4972-a475-215259d6264f","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(e){var n="https://s.go-mpulse.net/boomerang/";if("False"=="True")e.BOOMR_config=e.BOOMR_config||{},e.BOOMR_config.PageParams=e.BOOMR_config.PageParams||{},e.BOOMR_config.PageParams.pci=!0,n="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="47DAA-RMGFC-4U4YY-9C4XF-UTQN5",function(){function e(){if(!o){var e=document.createElement("script");e.id="boomr-scr-as",e.src=window.BOOMR.url,e.async=!0,i.parentNode.appendChild(e),o=!0}}function t(e){o=!0;var n,t,a,r,d=document,O=window;if(window.BOOMR.snippetMethod=e?"if":"i",t=function(e,n){var t=d.createElement("script");t.id=n||"boomr-if-as",t.src=window.BOOMR.url,BOOMR_lstart=(new Date).getTime(),e=e||d.body,e.appendChild(t)},!window.addEventListener&&window.attachEvent&&navigator.userAgent.match(/MSIE [67]\./))return window.BOOMR.snippetMethod="s",void t(i.parentNode,"boomr-async");a=document.createElement("IFRAME"),a.src="about:blank",a.title="",a.role="presentation",a.loading="eager",r=(a.frameElement||a).style,r.width=0,r.height=0,r.border=0,r.display="none",i.parentNode.appendChild(a);try{O=a.contentWindow,d=O.document.open()}catch(_){n=document.domain,a.src="javascript:var d=document.open();d.domain='"+n+"';void(0);",O=a.contentWindow,d=O.document.open()}if(n)d._boomrl=function(){this.domain=n,t()},d.write("<bo"+"dy onload='document._boomrl();'>");else if(O._boomrl=function(){t()},O.addEventListener)O.addEventListener("load",O._boomrl,!1);else if(O.attachEvent)O.attachEvent("onload",O._boomrl);d.close()}function a(e){window.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!window.BOOMR||!window.BOOMR.version&&!window.BOOMR.snippetExecuted){window.BOOMR=window.BOOMR||{},window.BOOMR.snippetStart=(new Date).getTime(),window.BOOMR.snippetExecuted=!0,window.BOOMR.snippetVersion=12,window.BOOMR.url=n+"47DAA-RMGFC-4U4YY-9C4XF-UTQN5";var i=document.currentScript||document.getElementsByTagName("script")[0],o=!1,r=document.createElement("link");if(r.relList&&"function"==typeof r.relList.supports&&r.relList.supports("preload")&&"as"in r)window.BOOMR.snippetMethod="p",r.href=window.BOOMR.url,r.rel="preload",r.as="script",r.addEventListener("load",e),r.addEventListener("error",function(){t(!0)}),setTimeout(function(){if(!o)t(!0)},3e3),BOOMR_lstart=(new Date).getTime(),i.parentNode.appendChild(r);else t(!1);if(window.addEventListener)window.addEventListener("load",a,!1);else if(window.attachEvent)window.attachEvent("onload",a)}}(),"".length>0)if(e&&"performance"in e&&e.performance&&"function"==typeof e.performance.setResourceTimingBufferSize)e.performance.setResourceTimingBufferSize();!function(){if(BOOMR=e.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var n="true"=="true"?1:0,t="",a="nml5ubaxbsitmynbh2fa-f-17bac5007-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,o={"ak.v":"32","ak.cp":"1137773","ak.ai":parseInt("677334",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"36d064e5","ak.r":36534,"ak.a2":n,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"107.23.218.0","ak.cport":35714,"ak.gh":"23.32.17.54","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1637957258","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==DeXXB8IbHbT01zC3ofS6QPdWtF1L08mnPTQrMOzD7ziDqdNXUMRAU6WS5J+8MZEgkXjvma8qI4svooVG0zRjNN8REm2lKsmt9e/9CE6mDRHvdIaJE8pccvppMkYq26GbUfnMGtnrzZfZ7o+f6+sZY9BishD54BZLgzsvDgKmhNN+xkVs46e624x3B/bvqnoM71tcgcKzX3cxg1HojQVzatzGbplEqYRGCiNTcKZNq+DAYjMshccAvXNlDrJGfdavZaZKcVNFVOmj7gHCcy7hZutQalgKqwxNt1MGpVWmt92M3QsV4V4EdOy8m5Z2b1fDcCJlgPfjrLwaabRhjKcYJxXlt4/Rml/1NBARFtGQP5qtGKzre1yGXWjcRWcGJxCjHHrOvjsCEaxhi4nSi2cLaVQMNcHI2ml9vn8kjuy3+HU=","ak.pv":"7","ak.dpoabenc":"","ak.tf":i};if(""!==t)o["ak.ruds"]=t;var r={i:!1,av:function(n){var t="http.initiator";if(n&&(!n[t]||"spa_hard"===n[t]))o["ak.feo"]=void 0!==e.aFeoApplied?1:0,BOOMR.addVar(o)},rv:function(){var e=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(e)}};BOOMR.plugins.AK={akVars:o,akDNSPreFetchDomain:a,init:function(){if(!r.i){var e=BOOMR.subscribe;e("before_beacon",r.av,null,null),e("onbeacon",r.rv,null,null),r.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="sales-navigation | d-none w-100 bg-primary-branding d-lg-flex"><div class="container-xl"><div class="sales-nav-links | d-flex justify-content-start py-1"><div class="sales-nav-link |"><a class="text-nowrap text-reset text-decoration-none" href="/page/advertise-with-us">Advertise With Us</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/health/back-on-track/">Back On Track</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="https://www.graytvlocal.com/market/central-virginia" rel="noopener noreferrer" target="_blank">Buy Local</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/health/coronavirus">Coronavirus Coverage</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/community/user-content">Send Us Your Pictures</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/page/virginia-lottery-holiday-cheer-lights-up-charlottesville/">Virginia Lottery Holiday Cheer</a></div></div></div></div><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/wvir.jpg?d=207&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/wvir.svg?d=207&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/wvir.svg?d=207&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/homepage">Home</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather/closings">Closings and Delays</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/sports">Sports</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community">Community</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/about-us">Inside 29</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/health">Health</a></li><li class="navbar-link | navbar-item d-none d-xl-flex"><a class="nav-link text-white" href="/2019/10/23/news-links/">News Links</a></li><li class="navbar-link | navbar-item d-none d-xl-flex"><a class="nav-link text-white" href="/livestream">Live Stream</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET" role="search"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Home</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Home navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings &amp; Delays</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics/election-results">Election Results</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream">Live Stream</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/capitol-square">Capitol Square News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/central-virginia">Central Virginia News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/charlottsville-albemarle">Charlottesville and Albemarle News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/gallery/2019/11/21/nbc-mugshots-gallery/">Mugshots Gallery</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/shenandoah-valley">Shenandoah Valley News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">Virginia News</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/submit-a-story/">Submit A News Tip</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/video-gallery/news/">Latest Video</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/7-day-forecast/">7-Day Forecast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/current-conditions/">Current Conditions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/radar-maps">Radar</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather/closings">Closings and Delays</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2021/08/09/nbc29-friday-night-fury-fan-cam/">Friday Night Fury Fan Cam</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community">Community</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Community navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/calendar">Community Calendar</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/pet-of-the-week">Pet of the Week</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/traffic/gas-prices">Gas Prices</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/food/mrfood">Mr. Food</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/skycam">NBC29 Skycam Archives</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/sunrise-stumper">Sunrise Stumper</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/community/community-conversations/">Community Conversations</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/video-gallery/community/community-conversations/">Community Conversations</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">Submit Photos and Videos!</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us">Inside 29</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Inside 29 navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/advertise-with-us">Advertise With Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2019/10/22/closed-captioning">Closed Captioning</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/careers">Jobs@NBC29</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/contests">Contests</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team">Meet the Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/back-on-track/">Back On Track</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/programming/schedule">Programming Schedule</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/sponsorship-request">Sponsorship Request</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/health">Health</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Health navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/back-on-track/">Back On Track</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/smj-monday">Sentara Martha Jefferson Monday</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/ritas-lunchbag">Rita&#x27;s Lunch Bag</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/coronavirus">Coronavirus Coverage</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="http://www.circleallaccess.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fullcourtgreta.com/" rel="noopener noreferrer" target="_blank">Full Court Press with Greta Van Susteren</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/live/16948/wvir%20news%2029" rel="noopener noreferrer" target="_blank">Watch Previous Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit WVIR on FACEBOOK" class="p-2" href="https://www.facebook.com/NBC29" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"><div class="alert-bar | bar-blue py-1"><div class="container-xl d-flex flex-row justify-content-between text-white font-weight-bold text-capitalize"><div class="d-flex flex-column justify-content-center"><a class="text-reset pointer" href="/weather/alerts/"><div class="alert-bar-text-container h6 mb-0"><span class="alert-bar-text d-inline-block">Special Weather Statement is in effect</span></div></a></div><div class="d-flex flex-column justify-content-center"><button class="dismiss-alert-bar btn btn-sm text-white" title="Dismiss Weather Alerts Alerts Bar"><i class="fas fa-times"></i><span class="sr-only">Dismiss <!-- -->Weather Alerts<!-- --> Alerts Bar</span></button></div></div></div></div><div id="fusion-static-enter:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div><div id="htmlBox-f0fgruVYP9iIdU" class="html-box | w-100 p-3 mb-3"><div class="html-box-container" id="htmlBox-f0fgruVYP9iIdU-container"><div class="mb-3" /></div></div><div id="fusion-static-exit:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div></nav><section class="leaderboard | w-100"></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Weibo Corporation Launches Global Offering</span></h1></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Nov. 26, 2021 at 2:40 PM EST</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->25 minutes ago</span></div></div><div class="article-body | article w-100"><p class="text | article-text"><span class="xn-location">BEIJING</span>, <span class="xn-chron">Nov. 26, 2021</span> /PRNewswire/ -- Weibo Corporation ("Weibo" or the "Company") (Nasdaq: WB), a leading social media platform in <span class="xn-location">China</span>, today announced the launch of its global offering (the "Global Offering") of an aggregate of 11,000,000 Class A ordinary shares of the Company. Weibo is offering 5,500,000 Class A ordinary shares of the Company (the "New Shares") and Sina Corporation (the "Selling Shareholder") is offering 5,500,000 Class A ordinary shares of the Company, which are to be converted from the Class B ordinary shares of the Company prior to the listing of Weibo's Class A ordinary shares on the Hong Kong Stock Exchange as defined below (the "Sale Shares," and together with New Shares, the "Offer Shares"). The Global Offering comprises of a <span class="xn-location">Hong Kong</span> public offering of initially 1,100,000 Class A ordinary shares commencing on <span class="xn-chron">November 29, 2021</span>, <span class="xn-location">Hong Kong</span> time (the "Hong Kong Public Offering") and an international offering of initially 9,900,000 Class A ordinary shares commencing today (including 5,500,000 Sale Shares) (the "International Offering"), and listing of Weibo's Class A ordinary shares on the Main Board of The Stock Exchange of Hong Kong Limited (the "Hong Kong Stock Exchange") under the stock code "9898."</p><p class="text | article-text">The Company's American depositary shares (the "ADSs"), each representing one Class A ordinary share of the Company, will continue to be listed and traded on the Nasdaq Global Select Market ("Nasdaq"). Investors in the Global Offering will only be able to purchase Class A ordinary shares and will not be able to take delivery of ADSs. Upon listing in <span class="xn-location">Hong Kong</span>, the Class A ordinary shares listed on the Hong Kong Stock Exchange will be fully fungible with the ADSs listed on Nasdaq.</p><p class="text | article-text">The initial number of Class A ordinary shares under each of the Hong Kong Public Offering and the International Offering represents approximately 10% and 90% of the total number of Class A ordinary shares initially available under the Global Offering, respectively, subject to re-allocation and over-allotment. Subject to the level of oversubscription in the Hong Kong Public Offering and pursuant to the claw back mechanism as described in the prospectus to be issued by the Company in <span class="xn-location">Hong Kong</span> dated <span class="xn-chron">November 29, 2021</span>, the total number of Class A ordinary shares available under the Hong Kong Public Offering could be adjusted to up to a maximum of 5,500,000 Class A ordinary shares, representing approximately 50% of the Class A ordinary shares initially available under the Global Offering. In addition, the Selling Shareholder expects to grant the international underwriters an over-allotment option to require it to sell up to an additional 1,650,000 Class A ordinary shares of the Company (to be converted from Class B ordinary shares) in the International Offering, representing approximately 15% of the total number of Class A ordinary shares initially available under the Global Offering.</p><p class="text | article-text">The offer price for the Hong Kong Public Offering (the "Hong Kong Offer Price") will be no more than <span class="xn-money">HK$388.00</span> per Class A ordinary share, or <span class="xn-money">US$49.80</span> per ordinary share (equivalent to <span class="xn-money">US$49.80</span> per ADS) (the "Maximum Hong Kong Offer Price"). The offer price for the International Offering tranche of the Global Offering (the "International Offer Price") may be set higher than, or the same as, the Maximum Hong Kong Offer Price. The Company will set the International Offer Price on or about <span class="xn-chron">December 2, 2021</span>, <span class="xn-location">Hong Kong</span> time, by taking into consideration, among other factors, the closing price of the ADSs on the Nasdaq on the last trading day on or before <span class="xn-chron">December 2, 2021</span> and investor demand during the marketing process. The final Hong Kong Offer Price will be set at the lower of the final International Offer Price and the Maximum Hong Kong Offer Price. The shares will be traded in board lots of 20 Class A ordinary shares.</p><p class="text | article-text">The Company plans to use the net proceeds from the Global Offering for continuing to grow its user base and user engagement, and enhance its content ecosystem, for research and development to enhance its user experience and monetization capabilities, for selectively pursuing strategic alliances, investments and acquisitions, and for working capital and general corporate purposes. The Company will not receive any proceeds from the sale of the Class A ordinary shares to be offered by the Selling Shareholder.</p><p class="text | article-text">Goldman Sachs (<span class="xn-location">Asia</span>) L.L.C., Credit Suisse (<span class="xn-location">Hong Kong</span>) Limited, CLSA Capital Markets Limited and China International Capital Corporation Hong Kong Securities Limited are the Joint Sponsors. Goldman Sachs (<span class="xn-location">Asia</span>) L.L.C., Credit Suisse (<span class="xn-location">Hong Kong</span>) Limited, CLSA Limited and China International Capital Corporation Hong Kong Securities Limited are Joint Representatives, Joint Global Coordinators, Joint Bookrunners and Joint Lead Managers for the proposed Global Offering.</p><p class="text | article-text">The International Offering is being made only by means of a preliminary prospectus supplement dated <span class="xn-chron">November 26, 2021</span> and the accompanying prospectus included in an automatic shelf registration statement on Form F-3 filed with the U.S. Securities and Exchange Commission (the "SEC") on <span class="xn-chron">November 26, 2021</span>, which automatically became effective upon filing. The registration statement on Form F-3 and the preliminary prospectus supplement are available at the SEC website at: <i><u><a href="http://www.sec.gov" rel="nofollow">http://www.sec.gov</a></u></i>.</p><p class="text | article-text">The proposed Global Offering is subject to market and other conditions, and there can be no assurance as to whether or when the Global Offering may be completed, or as to the actual size or terms of the Global Offering. This press release shall not constitute an offer to sell or the solicitation of an offer or an invitation to buy any securities of the Company, nor shall there be any offer or sale of these securities in any state or other jurisdiction in which such offer, solicitation or sale would be unlawful prior to the registration or qualification under the securities laws of any such state or other jurisdiction. This press release does not constitute a prospectus (including as defined under the laws of <span class="xn-location">Hong Kong</span>) and potential investors should read the prospectus of the Company for detailed information about the Company and the proposed Global Offering, before deciding whether or not to invest in the Company. This press release has not been reviewed or approved by The Stock Exchange of Hong Kong Limited or the Securities and Futures Commission of <span class="xn-location">Hong Kong</span>.</p><p class="text | article-text">The price of the Class A ordinary shares of the Company may be stabilized in accordance with the Securities and Futures (Price Stabilization) Rules. The details of the intended stabilization and how it will be regulated under the Securities and Futures Ordinance (Chapter 571 of the laws of <span class="xn-location">Hong Kong</span>) will be contained in the prospectus of the Company dated <span class="xn-chron">November 29, 2021</span>.</p><p class="text | article-text"><b>About Weibo</b></p><p class="text | article-text">Weibo is a leading social media for people to create, discover and distribute content. Weibo combines the means of public self-expression in real time with a powerful platform for social interaction, content aggregation and content distribution. Any user can create and post a feed and attach multi-media and long-form content. User relationships on Weibo may be asymmetric; any user can follow any other user and add comments to a feed while reposting. This simple, asymmetric and distributed nature of Weibo allows an original feed to become a live viral conversation stream.</p><p class="text | article-text">Weibo enables its advertising and marketing customers to promote their brands, products and services to users. Weibo offers a wide range of advertising and marketing solutions to companies of all sizes. The Company generates a substantial majority of its revenues from the sale of advertising and marketing services, including the sale of social display advertisement and promoted marketing offerings. Designed with a "mobile first" philosophy, Weibo displays content in a simple information feed format and offers native advertisement that conform to the information feed on our platform. To support the mobile format, we have developed and continuously refining our social interest graph recommendation engine, which enables our customers to perform people marketing and target audiences based on user demographics, social relationships, interests and behaviors, to achieve greater relevance, engagement and marketing effectiveness.</p><p class="text | article-text"><b>Safe Harbor Statement</b></p><p class="text | article-text">This press release contains forward-looking statements that relate to, among other things, Weibo's expected financial performance and strategic and operational plans (as described, without limitation, in the "Business Outlook" section and in quotations from management in this press release. Weibo may also make forward-looking statements in the Company's periodic reports to the SEC, in press releases and other written materials and in oral statements made by its officers, directors or employees to third parties. Statements that are not historical facts, including statements about the Company's beliefs and expectations, are forward-looking statements. These forward-looking statements can be identified by terminology, such as "will," "expects," "anticipates," "future," "intends," "plans," "believes," "confidence," "estimates" and similar statements. Forward-looking statements involve inherent risks and uncertainties. A number of important factors could cause actual results to differ materially from those contained in any forward-looking statement. Potential risks and uncertainties include, but are not limited to, Weibo's limited operating history in certain new businesses; failure to grow active user base and the level of user engagement; the uncertain regulatory landscape in <span class="xn-location">China</span>; fluctuations in the Company's quarterly operating results; the Company's reliance on advertising and marketing sales for a majority of its revenues; failure to successfully develop, introduce, drive adoption of or monetize new features and products; failure to compete effectively for advertising and marketing spending; failure to successfully integrate acquired businesses; risks associated with the Company's investments, including equity pick-up and impairment; failure to compete successfully against new entrants and established industry competitors; changes in the macro-economic environment, including the depreciation of the Renminbi; and adverse changes in economic and political policies of the PRC government and its impact on the Chinese economy. Further information regarding these and other risks is included in Weibo's annual report on Form 20-Fs and other filings with the SEC and the prospectus registered in <span class="xn-location">Hong Kong</span>. All information provided in this press release is current as of the date hereof, and Weibo assumes no obligation to update such information, except as required under applicable law.</p><p class="text | article-text"><b>Contacts</b></p><p class="text | article-text">Investors Relations <br/>Weibo Corporation<br/>Tel: +86-10-5898-3336<br/>Email: <a href="mailto:ir@staff.weibo.com" rel="nofollow" target="_blank">ir@staff.weibo.com</a></p><p class="text | article-text">View original content:</p><div class="interstitial-link | border-0 mb-3"><div class="p-2"><div class="align-self-center"><h6 class="mb-0 font-weight-bold"><a class="" href="https://www.prnewswire.com/news-releases/weibo-corporation-launches-global-offering-301432486.html">https://www.prnewswire.com/news-releases/weibo-corporation-launches-global-offering-301432486.html</a></h6></div></div></div><p class="text | article-text">SOURCE  Weibo Corporation</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img mb-0"><img class="img-fluid mx-auto d-block" height="300" src="https://gray-wvir-prod.cdn.arcpublishing.com/resizer/76lEYnOokAhlFB355U4sojfn9tU=/980x0/smart/filters:quality(85)/rt.prnewswire.com/rt.gif?NewsItemId=CN88894&amp;Transmission_Id=202111261440PR_NEWS_USPR_____CN88894&amp;DateId=20211126" width="980"/></div></figure></div><div class="article-body | article w-100"><p class="text | article-text"><i>The above press release was provided courtesy of PRNewswire. The views, opinions and statements in the press release are not endorsed by Gray Media Group nor do they necessarily state or reflect those of Gray Media Group, Inc.</i></p></div></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"></section><section class="body | w-100"></section><section class="recommendations | w-100"></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"></section></div><section class="bottom-wrapped | col-12"></section></div></div><footer class="footer | w-100"><div id="fusion-static-enter:footer-wvir" style="display:none" data-fusion-component="footer-wvir"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/homepage">Home</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community">Community</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us">Inside 29</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/livestream">Watch Live</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community/user-content">Submit Photos and Videos!</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">WVIR</li><li class="footer-contact | footer-address">503 E. Market St.</li><li class="footer-contact | footer-city-state">Charlottesville, VA 22902</li><li class="footer-contact | footer-phone">(434) 220-2900</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/WVIR-TV" rel="noopener noreferrer" target="_blank">FCC Public File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:viewercomments@nbc29.com" rel="noopener noreferrer" target="_blank">viewercomments@nbc29.com | 434-220-2900</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/wvir-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="http://webpubcontent.raycommedia.com/wvir/documents/EEOPublicFile.pdf" rel="noopener noreferrer" target="_blank">EEO Report</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/2019/10/22/closed-captioning/" rel="noopener noreferrer" target="_blank">Closed Captioning</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2021 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-wvir" style="display:none" data-fusion-component="footer-wvir"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>