<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9mtwxdx" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9mtwxdx";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Activist Delivers Petition Calling for Park Name Changes to City - NBC29 WVIR Charlottesville, VA  News, Sports and Weather</title>
<meta name="Description" content="Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks. "><meta name="KEYWORDS" content="NBC29,WVIR,Charlottesville,News,Sports,Weather,Central Virginia,Emancipation Park,Lee Park,City Council,Unite the Right,Mary Carey,Petition,Downtown Mall,Jason Kessler,Heather Hill"><meta name="news_keywords" content="NBC29,WVIR,Charlottesville,News,Sports,Weather,Central Virginia,Emancipation Park,Lee Park,City Council,Unite the Right,Mary Carey,Petition,Downtown Mall,Jason Kessler,Heather Hill"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2018/02/20"><meta name="owner" content="WVIR"><meta name="wn-version" content="ContainerE-Clip"><meta name="wn-build" content="7.4.8.8"><meta name="wn-base" content="IIS26"><meta name="wnreadableurl" content="activist-delivers-petition-calling-for-park-name-changes-to-city-council"><meta property="og:title" content="Activist Delivers Petition Calling for Park Name Changes to City Council"><meta property="og:type" content="article"><meta property="og:url" content="http://www.nbc29.com/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><meta property="og:image" content="http://wvir.images.worldnow.com/images/16131844_G.jpg"><meta property="og:description" content="Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks. "><link rel="canonical" href="http://www.nbc29.com/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Activist Delivers Petition Calling for Park Name Changes to City Council"><meta name="twitter:description" content="Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks. "><meta name="twitter:image" content="http://wvir.images.worldnow.com/images/16131844_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta name='rating' content='general'/><meta name='verify-v1' content='FPkLuq+6jkyKTmF6Kag28dov1C5wKlb9sn5lXsO9+98='/><meta name="google-site-verification" content="wPUILnLanNBpmp__41ELjDle_kuVgsTd3VtHftiYGvo" /><!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.4.8.8_7.4.4-6">
<link type="text/css" rel="stylesheet" media="all" href="http://WVIR.images.worldnow.com/interface/css/container-e.css?ver=2018-01-22%2012%3A04%3A34_7.4.4-6">
<!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.4.8.8"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.4.8.8"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.4.8.8"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu496 UL
                    , #menu496 .wnHorizontal { background-color: #081029; font-family: Verdana,Arial; font-size: 10px; font-weight: 700; color: #FFFFFF; }
                #menu496 A,
                    #menu496 LI.wnOn .wnSublevel A,
                    #menu496 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Verdana,Arial; font-size: 10px; font-weight: 700; color: #FFFFFF; }
                #menu496
                        .wnLevel1, #menu496
                        .wnLevel1 LI { height: 31px; }
                            #menu496 .wnHorizontal .wnDynamic .wnMenuTypeImage .wnSublevel LI { height: auto; }
                    #menu496 UL LI.wnOn { background-color: #18285A; color: #ffffff; }
                    #menu496 LI.wnOn A,
                        #menu496 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu496 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #ffffff; }
                    #menu496 .wnSublevel { background-color: #081029;  }
                #menu496 .wnSublevel A { border : 1px #18285A solid; border-top: none; }
                        #menu496 .wnSublevel .wnFirstNode { border-top : 1px #18285A solid; }
                        #menu496 .wnHorizontal .wnDynamic .wnMenuTypeImage .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu496 .wnSublevel LI.wnHasSublevel A { background: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu496 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu496 .wnSublevel LI.wnOn { background-color: #18285A;  }
                    #menu496 .wnLeft { background: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 1px; }
                    #menu496 LI.wnOn .wnLeft { background-image: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu496 .wnRight { background: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 1px; }
                    #menu496 LI.wnOn .wnRight { background-image: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu496 .wnRight .wnMiddle { background: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu496 LI.wnOn .wnMiddle { background-image: url('http://WVIR.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'WVIR',
            affiliateId : '505',
            baseUrl : 'www.nbc29.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.4.4-6',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '23',mdPartnerDomain : 'http://dub.nbc29.com'},
            registrationId : '556958',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://WVIR.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.4.8.8';
wng_pageInfo.template='ContainerE-Clip';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.disableSecurityWarning=false;
wng_pageInfo.containerType='V';
wng_pageInfo.ownerAffiliateName='WVIR';
wng_pageInfo.ownerAffiliateId=parseInt('505',10);
wng_pageInfo.containerId=parseInt('14140281',10);
wng_pageInfo.containerType='V';
wng_pageInfo.containerClass='clip';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/Clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Activist Delivers Petition Calling for Park Name Changes to City Council';
wng_pageInfo.pageTitle='Activist Delivers Petition Calling for Park Name Changes to City - NBC29 WVIR Charlottesville, VA  News, Sports and Weather';
wng_pageInfo.pageTitleTag='NBC29 WVIR Charlottesville, VA  News, Sports and Weather';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffWVIR';
wng_pageInfo.body._class='wnContainerType-clip wnLeftAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WVIR'},width:468,height:60,wncc:"News",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["30"]={id:"30",wnsz:"30",ownerinfo:{oldformat:1,owner:'nat',split:'20',type:'async',aff:'WVIR'},width:10,height:10,wncc:"News",parent:"WNAd30",type:"async",realvu:"",application:"video"};
wng_pageInfo.ads["31"]={id:"31",wnsz:"31",ownerinfo:{oldformat:1,owner:'nat',split:'20',type:'async',aff:'WVIR'},width:11,height:11,wncc:"News",parent:"WNAd31",type:"async",realvu:"",application:"video"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WVIR'},width:728,height:90,wncc:"News",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WVIR'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
</script>
<script type="text/javascript" src="http://WVIR.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2018-01-22%2012%3A04%3A34_7.4.4-6"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/WVIR.config.js?ver=7.4.8.8_7.4.4-6"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.4.8.8_7.4.4-6"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script><script type="text/javascript">_qacct="p-f7I_mcOtAjakY";quantserve();</script><noscript><a href="http://www.quantcast.com/p-f7I_mcOtAjakY" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-f7I_mcOtAjakY.gif" style="display: none" border="0" height="1" width="1" alt="Quantcast"/></a></noscript><script type="text/javascript" src="http://ftpcontent.worldnow.com/wvir/statcounter.js"></script><script type="text/javascript" src="http://www.statcounter.com/counter/counter.js"></script><link rel='alternate' type='application/rss+xml' title='NBC29 Local News' href='http://www.nbc29.com/Global/category.asp?C=85534&clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NB29 Local Sports' href='http://www.nbc29.com/Global/category.asp?C=85724&clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 Neighborhood News:  Albemarle County' href='http://www.nbc29.com/category/138424/neighborhood-news-albemarle-county?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 Neighborhood News:  Augusta County' href='http://www.nbc29.com/category/138428/neighborhood-news-augusta-county-waynesboro?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 Neighborhood News: Charlottesville' href='http://www.nbc29.com/category/135258/neighborhood-news-charlottesville?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 Neighborhood News: Capitol Square' href='http://www.nbc29.com/category/160436/neighborhood-news-capitol-square?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 News Video' href='http://www.nbc29.com/category/82958/pop_video_top?clienttype=rssmedia'><link rel='alternate' type='application/rss+xml' title='NBC29 National AP News' href='http://www.nbc29.com/category/13530/national-news?clienttype=rss'><link rel='alternate' type='application/rss+xml' title='NBC29 Virginia AP News' href='http://www.nbc29.com/category/50739/virginia-headlines?clienttype=rss'><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Poppins:400,500,600,700"><link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/normalize.css?ver=7.4.8.8"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/base.css?ver=7.4.8.8"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/layouts.css?ver=7.4.8.8"><link type="text/css" rel="stylesheet" href="//ftpcontent.worldnow.com/professionalservices/clients/wvir/custom.css?ver=7.4.8.8"><link type="text/css" rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css"><link type="text/css" rel="stylesheet" href="//cdnjs.cloudflare.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.css"><link type="text/css" rel="stylesheet" href="//cdn.jsdelivr.net/jquery.slick/1.5.6/slick.css"><script src="//ftpcontent.worldnow.com/professionalservices/clients/wvir/custom.js"></script><script src="//cdnjs.cloudflare.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js"></script></head><body id="WNAffWVIR" class="wnContainerType-clip wnLeftAlignment simple-a clip"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>var globalSharedAnalyticsData = { dma: '183', group: 'Waterman' }; (function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-170' ,"dma":globalSharedAnalyticsData.dma ,"group":globalSharedAnalyticsData.group})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<section class="header wn-bg-page-header"><header class="simple-a"><div id="Masthead" class="wnclear" style="background-image:url(http://WVIR.images.worldnow.com/images/static/hdr/hdr_branding.jpg)"><ul class="table row"><li class="branding"><a class="branding" href="/">Home</a></li><li class="tools"><ul class="membercenter inline wnMemberCenter wnMemberCenter-loggedOut" refresh="1"><li class="create wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a></li><li class="login wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a></li><li class="message wnMemberType-user"><strong></strong></li></ul><form class="search" action="/search" method="get"><input type="hidden" name="vendor" value="ez"><input class="text" type="text" name="qu" size="10" value="" placeholder="Search"><button class="submit wn-accent-a" type="submit">Go</button></form></li></ul></div></header></section><section class="main wn-bg-page-main"><div id="WNColsAll" class="columnsall wnColConfig"><div class="wn-sticky"><section class="nav wn-bg-page-nav"><nav class="simple-b main"><ul class="sf-menu sf-arrows sf-navbar"><li class=""><a class="sf-with-ul" href="/" target="">Home</a><ul><li class=""><a class="" href="/category/175730/live-stream-landing-page" target="">Livestream </a></li><li class=""><a class="" href="/category/175568/video-landing-page" target="">NBC29 Video News</a></li><li class=""><a class="" href="/category/262554/nbc-news-live-video" target="">NBC News Live Video</a></li><li class=""><a class="" href="/story/5466825/nbc29-rss-feeds" target="">RSS Feeds</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/82953/news" target="">News</a><ul><li class=""><a class="" href="/link/271403/news-home" target="">News Home</a></li><li class=""><a class="" href="/link/785918/albemarle-and-charlottesville-news" target="_blank">Albemarle and Charlottesville News</a></li><li class=""><a class="" href="/link/785937/ap-business-news" target="">Business News</a></li><li class=""><a class="" href="/link/785922/capitol-square-news" target="">Capitol Square News</a></li><li class=""><a class="" href="/link/785923/central-virginia-news" target="">Central Virginia News</a></li><li class=""><a class="" href="/link/785924/closings-and-delays" target="">Closings and Delays</a></li><li class=""><a class="" href="/category/327588/cnn-national-news" target="">CNN National News</a></li><li class=""><a class="" href="/link/785925/continuing-in-depth-coverage" target="">Continuing In-Depth Coverage</a></li><li class=""><a class="" href="/category/170695/talkers" target="">Daily Distraction</a></li><li class=""><a class="" href="/link/785936/ap-entertainment-news" target="">Entertainment News</a></li><li class=""><a class="" href="/link/785917/local-news" target="">Local News</a></li><li class=""><a class="" href="/link/785919/ap-national-news" target="">National News</a></li><li class=""><a class="" href="/link/785926/news-links" target="">News Links</a></li><li class=""><a class="" href="/link/785927/shenandoah-valley-news" target="">Shenandoah Valley News</a></li><li class=""><a class="" href="/link/785920/ap-strange-news" target="">Strange News</a></li><li class=""><a class="" href="/link/785928/submit-a-story-idea" target="">Submit a Story Idea</a></li><li class=""><a class="" href="/link/785921/ap-virginia-news" target="">Virginia News</a></li></ul></li><li class=""><a class="sf-with-ul" href="/weather" target="">Weather</a><ul><li class=""><a class="" href="/link/229852/weather-home" target="">Weather Home</a></li><li class=""><a class="" href="/category/324037/weather-7-day-forecast" target="">7 Day Forecast</a></li><li class=""><a class="" href="/category/96144/allergy-center" target="">Allergy Center </a></li><li class=""><a class="" href="/category/324043/animated-radar" target="">Animated Radar</a></li><li class=""><a class="" href="/category/324330/current-local-temperatures" target="">Current Temperatures</a></li><li class=""><a class="" href="/category/324040/weather-local-radar" target="">Radar Images</a></li><li class=""><a class="" href="/category/107632/weatherbug-live" target="">WeatherBug Live</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/85724/local-sports" target="">Sports</a><ul><li class=""><a class="" href="/link/271406/sports-home" target="">Sports Home</a></li><li class=""><a class="" href="/category/194453/acc-video-highlights-university-of-virginia" target="">ACC Video Highlights:  University of Virginia</a></li><li class=""><a class="" href="/link/272797/national-sports-news" target="">National Sports News</a></li><li class=""><a class="" href="/link/272794/virginia-sports-news" target="">Virginia Sports News</a></li><li class=""><a class="" href="/category/330834/winter-olympics-2018" target="">Winter Olympics 2018</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/85254/features" target="">Features</a><ul><li class=""><a class="" href="/link/271418/features-home" target="">Features Home</a></li><li class=""><a class="" href="/link/785908/community-calendar" target="">Community Calendar</a></li><li class=""><a class="" href="/category/326245/charlottesville-albemarle-spca-featured-pet-of-the-week" target="">Featured Pet of the Week</a></li><li class=""><a class="" href="/link/785909/gas-price-watch" target="">Gas Price Watch</a></li><li class=""><a class="" href="/link/785910/mr-food-test-kitchen-recipes" target="">Mr. Food Test Kitchen Recipes</a></li><li class=""><a class="" href="/link/785912/mugshots-slideshow" target="">Mugshots Slideshow</a></li><li class=""><a class="" href="/link/785911/nbc29-jobspot" target="">NBC29 JobSpot</a></li><li class=""><a class="" href="/link/785913/sunrise-stumper" target="">Sunrise Stumper</a></li><li class=""><a class="" href="/link/785914/traffic-watch" target="">Traffic Watch</a></li><li class=""><a class="" href="/link/785915/virginia-lottery" target="">Virginia Lottery</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/185903/programming" target="">Programming</a><ul><li class=""><a class="" href="/link/541871/programming-home" target="">Programming Home</a></li><li class=""><a class="" href="/story/37237359/nbc29-cw29-channel-lineup" target="">Channel Lineups: CW29, NBC29, Weather</a></li><li class=""><a class="" href="/link/437591/childrens-programming-changes" target="">Children's Programming Changes</a></li><li class=""><a class="" href="/link/572405/childrens-programming-descriptions" target="">Children's Programming Descriptions</a></li><li class=""><a class="" href="/link/437539/childrens-programming-report" target="">Children's Programming Report</a></li><li class=""><a class="" href="/category/317593/cw-programming" target="">CW Programming</a></li><li class=""><a class="" href="/link/785906/nbc-programming" target="">NBC Programming</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/85255/inside-29" target="">Inside 29</a><ul><li class=""><a class="" href="/link/271420/inside-29-home" target="">Inside 29 Home</a></li><li class=""><a class="" href="/link/785897/advertise-with-us" target="">Advertise With Us</a></li><li class=""><a class="" href="/link/785898/closed-captioning" target="">Closed Captioning</a></li><li class=""><a class="" href="/link/785899/contact-us" target="">Contact Us</a></li><li class=""><a class="" href="/link/785901/contest-winners" target="">Contest Winners</a></li><li class=""><a class="" href="/link/785900/jobs-nbc29" target="">Jobs @ NBC29</a></li><li class=""><a class="" href="/link/785904/member-center-faq" target="">Member Center FAQ</a></li><li class=""><a class="" href="/link/265581/nbc29-jobspot" target="">NBC29 JobSpot</a></li><li class=""><a class="" href="/link/785902/on-air-team" target="">On-Air Team</a></li><li class=""><a class="" href="/link/786228/sign-up-for-email-alerts" target="">Sign Up for Email Alerts</a></li><li class=""><a class="" href="/link/785903/sponsorship-request" target="">Sponsorship Request</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/92669/health" target="">Health</a><ul><li class=""><a class="" href="/category/220798/health-connection-lodge-at-old-trail" target="">Lodge at Old Trail</a></li><li class=""><a class="" href="/category/126975/ritas-lunch-bag" target="">Rita's Lunch Bag</a></li><li class=""><a class="sf-with-ul" href="/category/239877/sentara-martha-jefferson-monday" target="">Sentara Martha Jefferson Monday</a><ul><li class=""><a class="" href="/story/25415911/sentara-martha-jefferson-monday-what-is-peripheral-arterial-disease" target="">Sentara Martha Jefferson Monday: What is Peripheral Arterial Disease</a></li></ul></li><li class=""><a class="" href="/category/318830/straight-talk-md" target="">Straight Talk MD</a></li><li class=""><a class="" href="/category/126978/uva-house-call" target="">UVA House Call</a></li></ul></li></ul></nav></section></div><div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div></div><!--END WNCol23Top-->
<div id="WNContainerVideo" class="wnBlock videocontainer"><div class="wnGroup clip-info"><div class="wnItem clip-headline"><!--Clip Headline--><div id="wnClipHeadline"><h3>Activist Delivers Petition Calling for Park Name Changes to City Council</h3></div></div><div class="wnItem clip-header"></div><div class="wnItem videoplayer"><!--Video player--><div class="wnVideoCanvasContainer" id="wnVideoCanvasContainer1" style="width:640px;height:400px;overflow:hidden;position:relative;"><div id="wnVideoCanvas1" style="position: absolute; top: 0px;"></div></div><script type="text/javascript">
            var widgetVideoCanvasCP = new WNVideoWidget("WNVideoCanvas2", "wnVideoCanvas1", "Main");
            widgetVideoCanvasCP.SetWidth("640");
            widgetVideoCanvasCP.SetHeight("400");
            widgetVideoCanvasCP.SetSkin(CANVAS_SKINS.flat.silver);
            widgetVideoCanvasCP.SetVariable("clipId", "14140281");
            widgetVideoCanvasCP.SetVariable("transportShareButtons", "cc");
            widgetVideoCanvasCP.SetVariable("controlsType", "fixed");
            widgetVideoCanvasCP.SetVariable("overlayShareButtons", "email,link,share");
            
            try {
                if(wn.video.site.enableclippageautoplay) {
                    widgetVideoCanvasCP.SetVariable('isAutoStart', 'true');
                }
            }
            catch(e) {}

            widgetVideoCanvasCP.RenderWidget();
        </script></div><div class="wnItem clip-metadata"><div class="clip-byline-details"><!--Clip Byline--><div class="addthis-tool"><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
</div><div class="timestamp"><em class="wnDate">Posted:
<script type="text/javascript">
                                wnRenderDate('2/20/2018 8:37:55 AM EDT', '', false);</script>
</em><noscript><em class="wnDate">2/20/2018 8:37:55 AM EDT</em></noscript><!--END wnDate-->
<em class="wnDate">Updated:
<script type="text/javascript">
                                wnRenderDate('2/20/2018 8:39:54 AM EDT', '', false);</script>
</em><noscript><em class="wnDate">2/20/2018 8:39:54 AM EDT</em></noscript><!--END wnDate-->
</div></div><div class="clip-summary-details"><!--Clip Summary--><span id="WNStoryDateline">CHARLOTTESVILLE, Va. (WVIR) -
            </span><span><p>Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks.</p></span></div></div><div class="wnItem clip-ad"><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><div class="wnItem clip-comments"><!--Clip Comments--><div id="wnSocialToolsSection"><div id="WNMobdub"></div></div></div><div class="wnItem clip-gallery"><!--Video Gallery 1--><div id="wnVideoGalleryContainer11" style="width:640px;height:360px;overflow:hidden;position:relative;"><div id="wnVideoGallery11" style="position: absolute; top: 0px;"></div></div><script type="text/javascript">
            var WNVideoGalleryG1 = new WNVideoWidget("WNGallery", "wnVideoGallery11", "Main");
            
            WNVideoGalleryG1.SetVariable("rows", "3");
            WNVideoGalleryG1.SetVariable("columns", "2");
            WNVideoGalleryG1.SetStylePackage("flatlight");
            WNVideoGalleryG1.SetVariable("showTooltip", "true");
            WNVideoGalleryG1.SetWidth("640");
            WNVideoGalleryG1.SetHeight("360");
            WNVideoGalleryG1.RenderWidget();
        </script></div></div></div><!--END WNContainerVideo-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><!--DISPLAY SIZE 8: Feature - Col 2A-->
<div id="WNDS8" class="wnDS8 wnDSContainer-feature wnDS">
<div class="wnDSItems-feature">
<script>Worldnow.Helpers.debug('UB Disqus Commenting Code 2(496490)', 'UB_496490');</script><div class="wnDVUtilityBlock"><div id="disqus_thread"></div>
<script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/

var disqus_config = function () {
this.page.url = ('http://www.nbc29.com' + wng_pageInfo.permaLink); 
this.page.identifier = wng_page_containerId;
};



(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = 'https://nbc29.disqus.com/embed.js';
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>                                
                                </div><script>Worldnow.Helpers.debug('UB Disqus Commenting Code 2(496490)', 'UB_496490');</script></div><!--END wnDSItems-->
</div><!--
                END wnDS8-->
<div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<!--Video Gallery 2--><div class="debug hide" data-debug="Display Size 62 attempting to load..."></div><div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Most Popular Videos</span><span class="text abridgedHeadline">Most Popular Videos</span><a class="wnContent more enabled" href="/mostpopularvideo"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature Sport clip priority-1 odd displaySizeId-7 odd-7"><meta content="Sport"><meta content=""><h4 class="wnContent headline"><a href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><span class="text">Monday's High School Basketball Playoff Highlights</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><span class="text">Monday's High School Basketball Playoff Highlights</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16128611_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16128611_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Monday's high school basketball highlights.</p></span><a class="more" href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>Monday's high school basketball highlights.</p></span><a class="more" href="/clip/14139371/mondays-high-school-basketball-playoff-highlights"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14138529/married-uva-doctors-share-their-tips-on-balancing-the-personal-and-the-professional"><span class="text">Married UVA Doctors Share their Tips on Balancing the Personal and the Professional</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14138529/married-uva-doctors-share-their-tips-on-balancing-the-personal-and-the-professional"><span class="text">Married UVA Doctors Share their Tips on Balancing the Personal and the Professional</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summary abridged"><span class="text"><p>Doctors Brooke and Jeff Vergales are like any other married couple; they have two children, enjoy taking trips, and have a lot in common&hellip; including where they work.</p></span><a class="more" href="/clip/14138529/married-uva-doctors-share-their-tips-on-balancing-the-personal-and-the-professional"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>Doctors Brooke and Jeff Vergales are like any other married couple; they have two children, enjoy taking trips, and have a lot in common&hellip; including where they work.</p></span><a class="more" href="/clip/14138529/married-uva-doctors-share-their-tips-on-balancing-the-personal-and-the-professional"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport clip priority-3 odd displaySizeId-7 odd-7"><meta content="Sport"><meta content=""><h4 class="wnContent headline"><a href="/clip/14138598/uva-basketball-remains-ranked-1"><span class="text">UVa Basketball Remains Ranked #1</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14138598/uva-basketball-remains-ranked-1"><span class="text">UVa Basketball Remains Ranked #1</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14138598/uva-basketball-remains-ranked-1"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127030_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14138598/uva-basketball-remains-ranked-1"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16126921_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Virginia hosts Georgia Tech on Wednesday.</p></span><a class="more" href="/clip/14138598/uva-basketball-remains-ranked-1"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>Virginia hosts Georgia Tech on Wednesday.</p></span><a class="more" href="/clip/14138598/uva-basketball-remains-ranked-1"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature Weather clip priority-4 even displaySizeId-7 even-7 collapsed"><meta content="Weather"><meta content=""><h4 class="wnContent headline"><a href="/clip/14139354/nbc29-weather-forecast-10pm"><span class="text">NBC29 Weather Forecast 10PM</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14139354/nbc29-weather-forecast-10pm"><span class="text">NBC29 Weather Forecast 10PM</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14139354/nbc29-weather-forecast-10pm"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16128595_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14139354/nbc29-weather-forecast-10pm"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16128595_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnClear"></div></li><li class="wnItem feature Sport clip priority-5 odd displaySizeId-7 odd-7 collapsed"><meta content="Sport"><meta content=""><h4 class="wnContent headline"><a href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><span class="text">UVA Baseball Home Opener Moved to 5pm</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><span class="text">UVA Baseball Home Opener Moved to 5pm</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127067_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16126944_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>UVa baseball plays its home opener on Monday.</p></span><a class="more" href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>UVa baseball plays its home opener on Monday.</p></span><a class="more" href="/clip/14138547/uva-baseball-home-opener-moved-to-5pm"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-6 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><span class="text">Roslyn Farm Owners Offer Guests Traditional Farm Living Experience</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><span class="text">Roslyn Farm Owners Offer Guests Traditional Farm Living Experience</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127047_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127047_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Roslyn Farm in Albemarle County gives guests the opportunity to experience what it is like to live on a farm.&nbsp;</p></span><a class="more" href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>Roslyn Farm in Albemarle County gives guests the opportunity to experience what it is like to live on a farm.&nbsp;</p></span><a class="more" href="/clip/14138666/roslyn-farm-owners-offer-guests-traditional-farm-living-experience"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-7 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><span class="text">Activist Delivers Petition Calling for Park Name Changes to City Council</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><span class="text">Activist Delivers Petition Calling for Park Name Changes to City Council</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16131844_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16131844_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks.</p></span><a class="more" href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>Charlottesville City Councilors are getting closer to changing the names of Emancipation and Justice parks.</p></span><a class="more" href="/clip/14140281/activist-delivers-petition-calling-for-park-name-changes-to-city-council"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-8 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14136347/fluvanna-landowners-challenge-permit-for-automotive-recycling-center"><span class="text">Fluvanna Landowners Challenge Permit for Automotive Recycling Center</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14136347/fluvanna-landowners-challenge-permit-for-automotive-recycling-center"><span class="text">Fluvanna Landowners Challenge Permit for Automotive Recycling Center</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summary abridged"><span class="text"><p>A Fluvanna County property owner is calling on the Board of Supervisors to deny a special use permit that would allow an automotive recycling center to be built on 90 acres of farmland.&nbsp;</p></span><a class="more" href="/clip/14136347/fluvanna-landowners-challenge-permit-for-automotive-recycling-center"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>A Fluvanna County property owner is calling on the Board of Supervisors to deny a special use permit that would allow an automotive recycling center to be built on 90 acres of farmland.&nbsp;</p></span><a class="more" href="/clip/14136347/fluvanna-landowners-challenge-permit-for-automotive-recycling-center"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-9 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><span class="text">Artist Addresses Students and Staff at University of Virginia, Donates Painting</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><span class="text">Artist Addresses Students and Staff at University of Virginia, Donates Painting</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127117_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16127117_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>A Virginia native who is known for his extraordinary art spoke to students and faculty at the University of Virginia on February 19.</p></span><a class="more" href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p>A Virginia native who is known for his extraordinary art spoke to students and faculty at the University of Virginia on February 19.</p></span><a class="more" href="/clip/14138678/artist-addresses-students-and-staff-at-university-of-virginia-donates-painting"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><li class="wnItem feature News clip priority-10 even displaySizeId-7 even-7 collapsed last"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><span class="text">Middle School Students Compete in Debate Tournament</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><h4 class="wnContent headline abridged"><a href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><span class="text">Middle School Students Compete in Debate Tournament</span></a><span title="Play Video" class="wn-icon wn-icon-clip"></span></h4><div class="wnContent summaryImage left width90"><a href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16114207_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><img border="0" width="90" data-path="http://wvir.images.worldnow.com/images/16114207_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p><span style="color:black"><span style="font-family:arial,sans-serif"><span style="font-size:10.0pt">Students from the Charlottesville area participated in a middle school debate tournament to showcase their knowledge and communication skills.</span></span></span></p></span><a class="more" href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><span class="text">Full Story</span></a></div><div class="wnContent summary"><span class="text"><p><span style="color:black"><span style="font-family:arial,sans-serif"><span style="font-size:10.0pt">Students from the Charlottesville area participated in a middle school debate tournament to showcase their knowledge and communication skills.</span></span></span></p></span><a class="more" href="/clip/14135196/middle-school-students-compete-in-debate-tournament"><span class="text">Full Story</span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
</section><section class="footer wn-bg-page-footer"><footer class="simple-a row wn-main-a"><div class="flexbox stretch"><div class="flexitem auto search"><h4>Can't Find Something?</h4><form class="search" action="/search" method="get"><input type="hidden" name="vendor" value="ez"><input class="text" type="text" name="qu" size="10" value="" placeholder="Search"><button class="submit wn-accent-a" type="submit">Go</button></form></div><div class="flexitem auto branding" style="background-image:url(http://WVIR.images.worldnow.com/images/static/gfx/nav_top.gif)"></div><div class="flexitem auto contact"></div></div></footer></section><section class="nav wn-bg-page-nav"><nav class="simple-a main count-8 flexbox"><a data-id="82950" class="wn-main-a flexitem auto" href="/" target="">Home</a><a data-id="82953" class="wn-main-a flexitem auto" href="/category/82953/news" target="">News</a><a data-id="86412" class="wn-main-a flexitem auto" href="/weather" target="">Weather</a><a data-id="85724" class="wn-main-a flexitem auto" href="/category/85724/local-sports" target="">Sports</a><a data-id="85254" class="wn-main-a flexitem auto" href="/category/85254/features" target="">Features</a><a data-id="185903" class="wn-main-a flexitem auto" href="/category/185903/programming" target="">Programming</a><a data-id="85255" class="wn-main-a flexitem auto" href="/category/85255/inside-29" target="">Inside 29</a><a data-id="92669" class="wn-main-a flexitem auto" href="/category/92669/health" target="">Health</a></nav><script>
            $(function(){
                if(window.simpleMenuALoaded) return;
                var $body = $('body');
                var $columns = $('#WNCols234-5')
                var wipe = function() {
                    $body.removeClass(function (index, css) {
                        return (css.match (/(^|\s)nav-\S+/g) || []).join(' ');
                    });
                }
                $('nav.simple-a.main:first a').each(function() {
                    var $$ = $(this)
                    $$.on('hover',function() {
                        wipe()
                        $body.addClass('nav-feature-' + $$.data('id'))
                    })
                });
                $columns.on('mouseenter',wipe);
                window.simpleMenuALoaded = true;
            });
        </script></section><section class="footer wn-bg-page-worldnow"><footer class="worldnow row wn-accent-a"><p>
                    All content © Copyright 2000 - 2018 <a href="http://www.worldnow.com" target="_new">Frankly Media</a> and <span class="clientname" data-brandname="NBC 29 News" data-clientname="wvir"></span>. All Rights Reserved. For more information on this site, please read our <a href="/global/story.asp?s=18990">Privacy Policy</a>, <a href="/global/story.asp?s=18991">Terms of Service</a>, and <a target="policy" href="http://www.aboutads.info/choices/">Ad Choices</a>.
                </p></footer></section>
<!--
                Page Include: BODY--><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body--><script src="//cdn.jsdelivr.net/jquery.slick/1.5.6/slick.min.js"></script><script>$('section.block.displaysize-30').insertBefore('#WNCols234-5');</script><script>$('#WNAd52').appendTo('#WNCol4');</script>
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>